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Chapter 1. PACS Launch Pads
1.1. Introduction

Welcome to the PACS data reduction guide (PDRG) #. We hope you have gotten some good data from
PACS and want to get stuck in to working with them. This guide begins with a series of "launch pads"
that from Chap. 1; essentially quick-start guides to working with PACS data. These will show you the
fastest ways to get your data into HIPE, to inspect the HSA-pipeline reduced cubes (spectroscopy) or
images (photometry), and will outline what you need to consider before you start to reduce the data
yourself through the pipeline. For PACS observations we recommend you always re-reduce your data:
to include the latest calibrations, so that you can check the intermediate results (deglitching, map-
making and masking, flat-fielding, etc), and because some pipeline tasks are not carried out by the
automatic pipeline that the HSA-retrieved data were processed through.

Contents: Chap. 2 takes you through what you need to do and know before you start pipeline process-
ing your data, Chap. 3 is dealing with the different PACS photometry pipelines and Chaps 4 and 5
contain more detailed information about photometry data processing (e.g. deglitching and MADmap).
In the appendix are issues that are common to photometry and spectroscopy such as explained the
organisation and contents of PACS data products.

Additional reading can be found on the HIPE help page, which you can access from the HIPE
"Help>Help Contents" menu. This covers the topics of: HIPE itself, I/O, scripting in HIPE, and using
the various data inspection and analysis tools provided in HIPE. We will link you to the most useful
bits of this documentation—we do not repeat the information given there, only material that is PACS-
specific is in this PDRG. You can also consult the PACS public wiki for the Observer's Manual and
calibration information and documentation (herschel.esac.esa.int/twiki/bin/view/Public/PacsCalibra-
tionWed?template=viewprint). This is also linked from the PACS section of the HIPE help page. In-
formation on the calibration of PACS data is not covered in this PDRG, you have to look at the wiki
for these.

1.2. PACS Data Launch Pad
1.2.1. Terminology

The following Help documentation acronyms are used here (the names are links): DAG: the Data
Analysis Guide; SG, the Scripting Guide.

Level 0 products are raw and come straight from the satellite. Level 0.5 products have been partially
reduced, corrected for instrument effects generally by tasks for which no interaction is required by
the user. Level 1 products have been more fully reduced, some pipeline tasks requiring inspection
and maybe interaction on the part of the user. Level 2 products are fully reduced, including tasks that
require the highest level of inspection and interaction on the part of the user. Level 2.5 products, which
are found for some of the pipelines, are generally those where observations have been combined or
where simple manipulations have been done on the data.

Text written like this usually means we are referring to the class of a product (or referring to any
product of that class). Different classes have different (java) methods that can be applied to them and
different tasks will run (or not) on them, which it why it is useful to know the class of a product. See the
SG to learn more about classes. Text written like this is used to refer to the parameter of a task.

1.2.2. Getting your data from the archive into HIPE
There are a number of ways to get Herschel data into HIPE, and those data can come in more than
one format. The PACS pipelines use one method, which is documented in the pipeline script, but here
we give an overview of the simplest ways to get Herschel data into HIPE. This topic is covered in
detail chap. 1 of the DAG.
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Herschel data are stored in ESA's Herschel Science Archive (HSA),

• They are identified with a unique number known as the Observation ID (obsid)

• HIPE expects the data to be in the form of a pool, so HSA data must be imported into HIPE

• A pool is like a database, with observations organised as an Observation Context, containing
links to all the data, calibration, and supplementary files, and including the raw, partially-, and
fully-reduced data products

There are several ways to get observations imported from the HSA, or disk, into HIPE:

• Directly from the HIPE command line, using

obsid = 134....... # enter your own obsid
# to load into HIPE:
myobs = getObservation(obsid, useHsa=True) 
# to load into HIPE and at the same time to save to disk:
myobs = getObservation(obsid, useHsa=True, save=True) 

# You must be logged on to the HSA for this to work: 
# See the DAG sec. 1.4.5. 

See the DAG sec. 1.4.5 for more information on getObservation (for example, how to log-on to
the HSA before you can get the data). If you use the parameter save=True in getObservation then
the data are at the same time saved to disk to your MyHSA: note that saving can take a while.
Information and links about accessing MyHSA are also provided in sec. 1.4.5.

This method is useful for single observations and brings the data directly into HIPE in the format
that the PACS pipeline requires.

• Download a tar file (which is not a pool) from the HSA. See the DAG sec. 1.4.7  for more information
on this. This is the method to use if you have several observations, or a very large one.

If you are getting a tarfile, then you will have gone into the HSA, identified your observations, and
asked for them to be send via ftp. From the tar file you get, you will need to import the data into
HIPE. This is explained in the DAG sec. 1.5; to summarise, after having untarred the file you do
the following in HIPE:

#   Get the data from the HSA as a tarball
#   On disk, untar the tarball, e.g. 
cd /Users/me/fromHSA
tar xvf meme1342.tar

# in HIPE, then
myobsid=1342..... # enter your obsid
mypath="/Users/me/fromHSA/me1342
myobs=getObservation(obsid=myobsid,path=mypath)

# obsid is necessary only if more than one observation 
# is in that directory, i.e. if your tarfile has several 
# obsids in it

• Import directly into HIPE from the HSA via its GUI, which is useful for single observations and
brings the data directly into HIPE in the format that the PACS pipeline requires. This is covered
in the DAG sec. 1.4.5 ("using the GUI: HUI"). Briefly, you need to find your observation (e.g.
by obsid), then in the query results tab of the HUI, click the download icon to access a "Retrieve
Products" menu, from which select to download "All".

Tip

To get to the HSA from HIPE use the viewer from the HIPE menu Window>Show
View>Data Access>Herschel Science Archive. Anything you download directly into
HIPE from there will appear in the Variables pane of HIPE, and often the command will
also be echoed to the Console.
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After you have done this you can:

• If you loaded your data into HIPE using the first or third method above, then you must save the
observation to disk.

If using getObservation you can chose two ways to save the data to disk: either to your MyHSA,
using the parameter save=True in getObservation as explained above; or to a pool on disk, using
the command saveObservation.

To use saveObservation:

# "myobs" is the name of the ObservationContext
pooln = "NGC3333"
saveObservation(myobs, poolName=pooln)

where the observation goes to your local store (HOME/.hcss/lstore) to a directory (pool) with the
name that is either the obsid or as it given in poolName. The DAG does not explain saveObserva-
tion but it does explain the same parameters of getObservation: see sec. 1.7.

Note: if using saveObservation, the ObservationContext is not saved by default with the calibration
tree (calibration files) it was reduced with. If you wish to do that, see Sec. 2.6: you need to set
the parameter saveCalTree=True, which will save whatever calibration tree is in your Observation-
Context.

f you used the second method you do not need to save your observation as a pool, you could keep
them as they are. If you do want to convert your observation data on disk from the "HSA-format"
to the pool format, you can simply use saveObservation as in the example above.

• Once the data are saved to this pool with saveObservation, on your disk, then any other time you
want to access them you should use getObservation,

obsid = 134...... # enter your obsid here
pooln = "NGC3333"
myobs=getObservation(obsid, poolName=pooln)

The DAG explains these parameters of getObservation: see sec. 1.7 to know how to access the data
if they were saved elsewhere than your local store. The command will get the data as located in
the local store (HOME/.hcss/lstore) and with a directory (pool) name that is either the obsid (e.g.
"342221212") or the value set by poolName. You can also use a GUI to get data, e.g. from your
MyHSA: see sec. 1.7 of the DAG.

So, to summarise the command-line methods:

obsid = 134...... # enter your obsid here 

# Direct I
#   Get the data from the HSA and then save to 
#   /Users/me/.hcss/lstore/MyPoolName
myobs=getObservation(obsid, useHsa=True)
saveObservation(myobs, poolName="MyPoolName")
#   Then, to later get those data
myobs=getObservation(obsid, poolName="MyPoolName")
#
#   Get the data from the HSA and then save to 
#   /Users/me/.hcss/lstore/[obsid as a string]
myobs=getObservation(obsid, useHsa=True)
saveObservation(myobs)
#   Then, to later get those data
myobs=getObservation(obsid)

# You must be logged on to the HSA for this to work: 
# See the DAG sec. 1.4.5. 
# See Sec. 2.6 to learn about saving and then 
# restoring the caltree
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# Direct II
#   Get the data from the HSA and immediately save 
#   to /Users/me/.hcss/lstore/MyPoolName
myobs=getObservation(obsid, useHsa=True, save=True, poolName="MyPoolName") 
#   Then to later get those data
myobs=getObservation(obsid, poolName="MyPoolName")

# DIRECT III
#   Get the data from the HSA as a tarball
#   On disk the data are in directories off of /Users/me/fromHSA
#   In HIPE, then
myobsid=1342..... # enter your obsid
mypath="/Users/me/fromHSA/me1342
myobs=getObservation(obsid=myobsid,path=mypath)
obsid = 134...... # enter your obsid here 
mypath="/Users/me/fromHSA/me1342
myobs=getObservation(obsid=myobsid,path=mypath)

For the GUI-based methods, read chap. 1 of the DAG. For full parameters of getObservation, see its
URM entry: here. (Note: there are two "getObservation"s in the URM. The one I link you to is the
correct one, it is also the first in the URM list.)

1.2.3. Looking at your fully-reduced data
Once the data are in HIPE, the ObservationContext will appear in the HIPE Variables panel. To look
at the fully-reduced, final Level 2 product (images for the photometer) do the following,

• Double-click on your observation (or right-click and select the Observation Viewer)

• In the directory-like listing on the left of the Observation viewer (titled "Data"), click on the + next
to the "level2"

• Go to HPPMAPB to get the blue map or the HPPMAPR to get the red Naive map. The map will
open to the right of the directory-like listing, but if you want to view it in a new window then instead
double-click on the "HPPMAPB" (or right-click to select the Standard Image Viewer

To learn more about the layers of the ObservationContext and what the products therein are, see the
PPE in PACS Products Explained.

1.3. PACS Photometry Launch Pad
The following Help documentation acronyms are used here: DAG: the Data Analysis Guide; PDRG:
PACS Data Reduction Guide.

1.3.1. Does the observation data need re-processing?
The PACS ICC recommend that you always reprocess your data,

• The pipeline tasks and the calibrations are still undergoing improvement and the pipeline that the
reduced data you got from the HSA may not have been the most recent

• There are some pipeline stages that for all but the most simple data you ought to inspect the results
of the pipeline task yourself, to decide if you wish to change the default parameters

Information about calibration files held in the calibration tree:

• When you start HIPE, HIPE will begin by looking for a calibration file update: Sec. 2.5.1.
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• To check what version of calibration files and the pipeline your HSA-gotten data were reduced with,
and to compare that to the current version and to see what has changed, see Sec. 2.5.4.

• You can also look at the Meta data called calTreeVersion, see Sec. 2.5.4.

• To load the calibration tree into HIPE when you pipeline process, see Sec. 2.5.3.

1.3.2. Re-processing with the pipeline scripts
The subsequent chapter of the PDRG, linked to below, cover different pipelines each.

The pipeline script you will run will depend on the observing mode and the science target,

• Chopped point source data: see Sec. 3.3 for observations taken in chop-nod photometry mode (an
old mode).

• scan-map and mini scan-map for point sources: see Sec. 3.2.1 for observations containing mainly
point sources and small extended sources

• Extended sources using MADMap: see Chap. 3.2.2 for observations of extended sources (only use
when scan and cross scan data are taken).

• Extended source using JScanam see Sec. 3.2.3 for observations of extended sources (only use when
scan and cross scan data are taken).

• Extended source using Unimap see Sec. 3.2.4.2 for observations of extended sources.

• The pipeline scripts contain all the pipeline tasks and simple descriptions of what the task are doing.
But if you want to know all the details you need to consult the pipeline chapters (links above).
Individual pipeline tasks are also described in the PACS User's Reference Manual (PACS URM).

• The pipelines take you from Level 1 ((calibrated data cubes in Jy/detector pixel)) to Level 2 (ful-
ly-processed). If a Level 2.5 is done, that means maps have been combined.

To access the scripts, go to the HIPE menu Pipelines>PACS>Photometer. The scripts assume:

• The data are already on disk or you can get them from the HSA using getObservation (so you must
know the Observation ID)

• You have the calibration files on disk; normally you will use the latest update, but you can run with
any calibration tree version: see Sec. 2.5.3 to know how to change the version of the calibration
tree you are using.

• You chose to do the red or the blue camera separately

To run the scripts,

• Read the instructions at the top, and at least skim-read the entire script before running it

• Although you can run most all in one go, it is highly recommended you run line by line at least
for the first time

• If you are going to comment within the script or change parameters, then first copy the script to
a new, personalised location and work on that one (HIPE menu File>Save As): otherwise you are
changing the script that comes with your HIPE installation

As you run the scripts,

• Plotting and printing tasks are included with which you can inspect the images and masks them-
selves. The plots will open as separate windows
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• The scripts will save the data into FITS files after each Level (this is a difference with the spec-
troscopy pipeline)

1.3.3. Considerations when running the pipeline
Considerations concerning the technicalities of running the pipeline are:

• If you chose to run the pipeline remotely or as part of bulk processing you might want to disable
the plotting tasks by commenting out the lines starting with "Display(...)"

• Memory vs speed: the amount memory you assign to HIPE to run the pipeline depends on how
much data you have, but >=4Gb for sure is recommended.

If you wish to fiddle with your data (other than using the plotting tasks provided in the pipeline) it
would be a good idea to do that in a separate running of HIPE.

• Save your data at least at the end of each Level, because if HIPE crashes you will lose everything
that was held only in memory (the scripts, by default save your data after each Level so DO NOT
modify that part)

Things to look out for in your data as you run the pipeline are:

• Saturated and Glitched data

• Non-smooth coverage map (the coverage map is not uniform but the transitions should be fairly
smooth towards the edges)

• Up and down scan offsets (distorted Point Spread Function)

• Dark spots around bright point sources (sign of inappropriate high-pass filtering)

1.3.4. Further processing
There are a number of tasks that can be used to inspect and analyse your PACS Level 2 images. For a
first quick-look inspection (and even for some image manipulation) we recommend the tasks' GUIs.
The tasks are listed in the Tasks panel under Applicable if the image is highlighted in the Variables
panel. Double-click on the task will call up its GUI, except for the Standard Image Viewer which
is invoked by a right-click on the image in the Variables panel and selecting Open with>Standard
Image Viewer

• If you just want to look at the images you can use the Standard Image Viewer: see Sec 4.4 of
the DAG:

• The annularAperturePhotometry task: (see Sec 4.21 of the DAG) Performs aperture photometry
using simple circular aperture and a sky annulus. There are other aperture photometry tasks: fixed-
Sky, pacsAnnularSky, rectangular.

• The sourceExtractorDaophot and sourceExtractorSussextractor: (see Sec 4.19 of the DAG)
Extracts sources from a simple image using different algorithms.

• The sourceFitter: (see Sec 4.20 of the DAG ) Fits a 2D Gaussian to a source in a specified rectan-
gular region on an image.

See the image analysis chapter of the Data Analysis Guide chap. 4 for more information on image
processing in HIPE.
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